Arhive blog

Daca folosesti Internet Explorer, atunci executa codul html…


La un proiect, am avut  de portat un site cu un cms foarte primitiv in WordPress… Ei bine modificarile facute nu se vad corect pe versiunea de Internet Explorer 8 si mai mici. Dupa ce am citit cateceva pe ici, pe colo, am vazut ca Google nu mai suporta Internet Explorer 8.

Totusi va recomand sa aveti un fisier ie.css, in care realizati designul doar in cazul in care vizitatorul siteului la care lucrati are Internet Explorer.

Si mai ales trebuie sa faceti un cod special in prima linie din body pentru vizitatorii cu browsere vechi si anume:

 <!–[If IE]> <div> <br /> <font color=”red” > Your browser is outdated. Please upgrade your browser from: <a href=”http://browsehappy.com/” target=”_blank”>http://browsehappy.com/</a> for a better experience. Thank you!</font></div> <![endif]–>

Deci, ce face codul? Daca vizitatorul siteului vostru indeplineste conditia de a avea o versiune de Internet Explorer mai mica decat 9 atunci va aparea un text rosu in care este rugat sa isi faca update la browser folosind siteul respectiv. Cu chestia asta, nu doar ca oferiti vizitatorilor cel mai nou si mai bun browser preferat de ei.

Deci codul de fapt e asta :

<!--[If IE]> Cod HTML <![endif]-->

Mai multe pe : http://www.unintentionallyblank.co.uk/2006/09/19/if-internet-explorer-then-do-something-else-a-how-to/

Internet Explorer 7 Logo

Internet Explorer 7 Logo (Photo credit: dannysullivan)

%d blogeri au apreciat: